Використання Visual Basic for Application у Microsoft Excel
Работа добавлена: 2015-12-13





МІНІСТЕРСТВО ОСВІТИ І НАУКИ,  МОЛОДІ ТА СПОРТУ УКРАЇНИ

ДОНЕЦЬКИЙ НАЦІОНАІЛЬНИЙ УНІВЕРСИТЕТ  ЕКОНОМІКИ І ТОРГІВЛІ

імені  Михайла ТУГАН-БАРАНОВСЬКОГО

Кафедра інформаційних систем і технологій управління

Лабораторна робота №7

«Використання Visual Basic for Application у Microsoft Excel»

                                                                

              Виконала

                                                                     студентка группи БС-10-А

Тищенко Марина

    Перевірив:

             Роттер М. В.

Донецк-2011

Варіант №13

Створити таблицю «Розрахунок сум на рахунках фізичних осіб», розрахунок підсумкових значень у який по рядках і в цілому по таблиці виконується за допомогою командної кнопки «Розрахунок».  За допомогою кнопки «Очищення» можна видалити вміст інформаційних рядків таблиці і підсумковий рядок.

Рис. 1.1. – Результат роботи з рахунками фізичних осіб

Рис. 1.2. – Виведення формул у чарунках

Дані в рядку коду

                       Коментар

Private Sub cmdR_Click()

Заголовок процедури, яка виконуватиметься після натискання на кнопці “Розрахунок”.

k = 0

Змінній k, яка використовується для підрахунку  заповнених рядків таблиці, привласнюється значення 0.

For i = 6 To 20

Для і від 6 до 20 виконуються дії в циклі. 6 це номер першого заповненого рядка таблиці, 20 номер максимального можливого заповненого рядка.

If Cells(i, 3).Value <> 0 And Cells(i, 4).Value <> 0 And Cells(i, 5).Value <> 0 Then

Якщо для рядка і стовбця 3,4,5 вміси чарунки не дорівнює 0…

k = k + 1

Змінна k збільшується на 1.

Cells(i, 6).FormulaR1C1 = "=RC[-3]*(1+RC[-1]/100)^RC[-2]"

у чарунку  Cells(i, 6) для виведення  суми на рахунку записується формула =(Сі*(1+1/Eі)^Di(=(C6*(1+1/E6)^D6.

Cells(i, 6).NumberFormat = "0.00"

Для чарунки, у якій виводиться відсоток відхилення, визначається числовий формат з двома знаками після десяткової крапки.

End If

Кінець оператору If.

Next i

Кінець циклу для розрахунку відхилень і визначення кількості заповнених рядків таблиці.

Cells(k + 4, 1).Formula = "Разом:"       

У чарунці з адресою рядок – k+4, стовпчик 1 виводиться текст "Разом:".

   Cells(k + 4, 3).FormulaR1C1 = "=Sum(R3C3:R[-1]C3)"

У чарунку для розрахунку підсумкового значення по сумах фактичної реалізації вводиться формула =СУММ(С3:С(k+1-1)).

       Cells(k + 4, 4).FormulaR1C1 = "=Sum(R3C4:R[-1]C4)"

У чарунку для розрахунку підсумкового значення по сумах фактичної реалізації вводиться формула =СУММ(D3:С(k+1-1)).

Cells(k + 4, 5).FormulaR1C1 = "=Sum(R3C5:R[-1]C5)"

У чарунку для розрахунку підсумкового значення по сумах фактичної реалізації вводиться формула =СУММ(E3:С(k+1-1)).

Cells(k + 4, 6).FormulaR1C1 = "=Sum(R3C6:R[-1]C6)"

У чарунку для розрахунку підсумкового значення по сумах фактичної реалізації вводиться формула =СУММ(F3:С(k+1-1)).

End Sub

Кінець процедури.

Private Sub cmdClear_Click()

Заголовок процедури, яка виконуватиметься після натискання на кнопці “Очищення ”.

 For i = 6 To 20

Для і від 6 до 20 виконуються дії в циклі. 6 це номер першого заповненого рядка таблиці, 20 номер максимального можливого заповненого рядка.

       For k = 1 To 6

Для k від 1 до 6 виконуються дії в циклі. 1 це номер першого заповненого рядка таблиці, 6 номер максимального можливого заповненого рядка.

              Cells(i, k).FormulaR1C1 = ""

У чарунку  Cells(i, k) записується пусте значення

        Next 

Кінець циклу k

 Next

Кінець циклу i

End Sub

Кінець процедури.




Возможно эти работы будут Вам интересны.

1. Microsoft Office Programmability in C# and Visual Basic

2. Використання надбудови Пошук розв’язку електронних таблиць Microsoft Excel

3. Інструкція для створенняWindowsForm Application (C++) в Visual Studio 2013

4. Основи алгоритмізації та програмування на Visual Basic

5. Программа на языке программирования Visual Basic для вычисления выражения

6. Знайомство з середовищем розробки Microsoft Visual Studio.NET. Структура програми на C#. Основи мови C#

7. Решение задачи нелинейного программирования с использованием Microsoft Excel

8. Обработка экспериментальных данных в металлургии с использованием Microsoft Excel

9. Понятие и использование средств управления Visual FoxPro. Создание отчетов в Visual FoxPro

10. Enhancing PlanMyNight ASP.NET MVC Application